Back to overview
Maintenance

Update - v2.1.4beta5

Nov 18 at 03:00am EST  –  Nov 18 at 03:10am EST
Affected services
API

Resolved
Nov 18 at 03:00am EST

Updating Cloud to latest version.
Check discord.gg/planetary for more info.